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1. Introduction
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Overview of image processing & analysis

1.1. Experimental design

1.2. Image processing: restoration, filtering & segmentation

1.3. Image analysis: measurement, automation, statistics

1.4. Review of image processing & analysis tools
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choice of fluorophoreschoice of fluorophores

1.1. Experimental design
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What am I trying to measure?

Expression level? 

Distance or colocalization?

Dynamics?

accurate, calibrated intensities

contrast-to-noise, resolution, alignment

temporal resolution, photostability

decide on the instrument (& technique)
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1.2. Image Processing
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Image restoration

Denoising / noise filtering - smoothing, neighborhood filters, non-local 

Flat-field correction - uneven illumination (also, pseudo-correction) 

Deblurring - deconvolution with or without PSF, unsharp mask

Image registration - rigid/affine versus elastic - intensity-based or feature-based 

Normalization - intensity of each time-point scaled to correct bleaching (& flicker)
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1.2. Image Processing
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Image filtering

Spatial filters for smoothing & sharpening

Frequency domain filters

Adaptive filtering versus transformation + global filtering

Time-domain filtering (see temporal median filter in Section 2, Tracking)
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1.2. Image Processing
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Image restoration & filtering

pseudo-flat field

Im = Im-mean * Im/mean-filtered FFT reveals frequencies registration can

be critical!

original 3x3 median

3-25 bandpass

240x240 mean-filt

original

pseudo-corrected
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1.2. Image Processing
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Segmentation

Simple intensity thresholding - ROI or binary image  

Spot/particle detection - intensity, size and shape

Edge detection (e.g. Sobel) & Morphological image processing* (erosion, dilation)

Watershed calculation, Voronoi diagram, Ultimate eroded points

Machine learning and Manual options 
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1.2. Image Processing
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Segmentation Image > Adjust > Threshold (Set) 

Analyze > Analyze particles  

Use: Analyze > Tools > ROI manager

 (“wand” to select individual ROIs)

Process > Find edges     uses Sobel detector

Process > Binary    menu contains MIP (erode, dilate etc.)

Binary processing “Watershed” separates touching edges

“Voronoi” finds lines equidistant from feature centres
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1.3. Image Analysis
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Measurement, automation & statistics

Quantitative results: care, consistency, avoid systematic errors, avoid bias* 

Manual analysis vs. Macros vs. customized software tools for automation

In addition to Excel, other useful statistics software: R, MATLAB 

* recommend blind analysis to avoid bias

http://microna.bioch.ox.ac.uk/mediawiki/index.php/Fiji_/_ImageJ

9

mailto:graeme.ball@bioch.ox.ac.uk
mailto:graeme.ball@bioch.ox.ac.uk
http://microna.bioch.ox.ac.uk/mediawiki/index.php/Fiji_/_ImageJ
http://microna.bioch.ox.ac.uk/mediawiki/index.php/Fiji_/_ImageJ


1.4. Image Analysis Tools
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Free tools

ImageJ / Fiji - versatile 2D+ image analysis tool with many plugins

CellProfiler - quantitatively measure cell phenotype (+ Worm Toolbox)

Icy, Vaa3D, BioimageXD - 3D image visualization & analysis

Priism/IVE, Priithon & Editor - 2D image processing/analysis (DV/OMX)

OMERO - image repository & visualization
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1.4. Image Analysis Tools
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Commerical tools

MATLAB - custom analysis using Image Processing toolbox 

Imaris, Amira - 3D visualization & analysis packages

SoftWoRx - API Deltavision, deconvolution, SI reconstruction

Metamorph - microscope control, image processing/analysis

Huygens, AutoQuant - Deconvolution software

Volocity - 3D visualization & analysis package, spinning disk 
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2. Image Analysis Examples
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2.1. 3D visualization and analysis options

2.3. Building an analysis Macro in ImageJ/Fiji

2.2. 3D visualization & analysis using volocity - colocalization

2.4. Tracking using a custom MATLAB pipeline

2.5. MicrobeTracker: analyzing dynamic fluorescent foci within cells 

2.6. Data management and processing with OMERO 
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2.1. 3D visualization & analysis
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• ImageJ/Fiji has 3D visualization & analysis fucntionality: 

     3D viewer, Volume Viewer, Image 5D, hyperstacks, orthogonal view, 

     3D objects counter

• Imaris, Amira and Volocity are 3D image visualization & analysis packages 

     designed for microscopy (and medical imaging)

• Choice between viewing fluorescence intensity (often MIP) versus 

     generating surface representations of objects  
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2.2. Volocity
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Volocity - 3D visualization & analysis 

• produced by Improvision (acquired by PerkinElmer) 

• drives PerkinElmer’s spinning disk confocal microscopes

• 3D visualization/analysis & movie-making quite good, +FRAP, FRET, coloc.

• slightly odd to use initially - “libraries” and “measurement tasks/protocols”

 http://www.perkinelmer.com/PDFs/downloads/CreatingMeasurementProtocolVolocitySoftware.pdf

• slicker than ImageJ, but a lot more expensive! (support though)
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2.2. Volocity
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 http://www.perkinelmer.com/PDFs/downloads/CreatingMeasurementProtocolVolocitySoftware.pdf
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2.2. Volocity - XY Plane view
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Image of immune cell by Konstantina Nika (Acuto lab, Dunn School)

  red/green: antibody staining of (non-)/phosphorylated membrane protein,

  blue = DAPI

acquired using OMX V2 (with Eva’s help)
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2.2. Volocity - XYZ view
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2.2. Volocity - 3D opacity (MIP)
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2.2. Volocity - colocalization
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2.2. Colocalization 101
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• make very certain that 

1. you do not have bleed-through!

2. your channel alignment is properly calibrated

3. your images are as deblurred as possible 

• many colocalization statistics rely on segmenting both channels

     => flat field & meticulous background correction, justifiable ROI & threshold

• read this review:-

http://www.ncbi.nlm.nih.gov/pubmed/17210054

• 3 fundamental approaches: 

1. intensity correlation (Pearson) / scatter plot

2. overlap coefficients (Manders: M1, M2)

3. object-based analysis

JaCoP
(ImageJ plugin)
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2.2. Colocalization 101
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Fig. 5E (Bolte & Cordelieres)

M1=0.053 M2=0.941
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2.3. Fiji/ImageJ tips
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• useful tools that are easy to miss: the wand, ROI manager, brush selection

• understand how to manipulate stacks, hyperstacks and virtual stacks -

     e.g. how to convert, project, reduce, combine; channels tool 

• make use of image histogram, “plot profile” and threshold tool

• learn how to “set measurements” and measure

• read the manual: http://rsbweb.nih.gov/ij/docs/user-guide.pdf
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2.3. Fiji/ImageJ Macros
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• first, try out some processing/analysis options manually

• turn on the recorder ... “Plugins > Macros > Record”

• you will see a command equivalent to every task you carry out 

• paste a sequence of commands into new Macro (Plugins > New > Macro) 

• for a description of how Macros work and info about in-built functions, see -

     http://rsbweb.nih.gov/ij/developer/macro/macros.html

     http://rsbweb.nih.gov/ij/developer/macro/functions.html

• result: gbSumMaskedSignal.ijm; for NMJ screen, James Halstead (Davis Lab)
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2.4. MATLAB: image processing
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• MATLAB is not free, but many academic institutions have licenses

• Much quicker and easier to prototype new algorithms in MATLAB 

     than e.g. C++ or java

• MATLAB is interactive, can use Bioformats to open images, and has 

     an extremely powerful image processing toolbox 
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2.4. Tracking in MATLAB
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Custom particle tracker

• Based on Single Particle Tracker from the MOSAIC group (ETH Zurich),

      which is available as ImageJ plugin and MATLAB code

I. F. Sbalzarini and P. Koumoutsakos. Feature Point Tracking and Trajectory Analysis for 

  Video Imaging in Cell Biology, Journal of Structural Biology 151(2):182-195, 2005.

• Used MATLAB to build up a custom processing and detection scheme

• See: http://www.ncbi.nlm.nih.gov/pubmed/21746854
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1. Image restoration / filtering

example of a custom intensity 
transform: scale according to 
local median

raw data showing uneven illumination ‘normalized’ image
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Image segmentation: thresholding
  - a global threshold only works if the image is very ‘even’

2. Feature extraction

  => ‘adaptive thresholding’, or prior normalization

using raw data using ‘normalized’ data
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Image segmentation: identifying ‘foreground’ features

  - easy to implement custom filters in MATLAB, like this 

     temporal median filter to identify moving foreground

2. Feature extraction

time

median

median + X

particle event

In
te

ns
ity

X
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Image segmentation: identifying ‘foreground’ features

2. Feature extraction

200x200 area, normalized 200x200 area, non-background (‘foreground’)
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LOW

square Haar-like feature

outer region
inner region

central pixel

LOWMEDHIGHHIGHMEDLOWLOW

Object recognition

  - many tools for point, line & edge detection in MATLAB

  - generally work by either: 

       - applying a mask to find maxima

           or

       - calculating intensity gradient (steep gradient = edge)

2. Feature extraction

  e.g. detection of Haar-like features to find particles
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2.4. Tracking in MATLAB
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Custom particle tracker

final “particle image” with tracks MOSAIC imageJ tracker results
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2.4. Tracking in MATLAB
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Tracking

Most common scheme: process, detect/refine, link, correct

Reliable automatic detection is usually the hard part

Two essential prerequisites:-

1. contrast-to-noise ratio of >4

2. displacement per. frame less than inter-particle distance
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2.5. MicrobeTracker
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Analysis of fluorescent foci in simple cells

a MATLAB program that can easily be modified or extended 

http://emonet.biology.yale.edu/microbetracker/
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2.6. OMERO
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Image repository, viewer + processing/analysis

& IJ plugin!

“OMERO.insight”
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Patch-based denoising: 10-100 x less light?

Jerome Boulanger: SAFIR Denoising software

Integrated into Priism by the John Sedat Group UCSF  
J. Boulanger, C. Kervrann, and P. Bouthemy, “Space-time adaptation for
patch-based image sequence restoration,” IEEE Trans. on Pattern Analysis
and Machine Intelligence, vol. 29, no. 6, pp. 1096ñ1102, June 2007

Macrophage: Jupiter-GFP 7Z, 3stacks/s (Richard Parton)

8 ms exposure, 10% 488 Laser power 8 ms exposure, 0.1% 488 Laser power
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3. Summary
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• importance of experimental design & optimization - identify problems early

Overview of image processing & analysis

• Demo

• feedback - problems you are interested in that I haven’t covered

• keep data secure, well-organized and annotated

• automation: is it necessary? if so, ask / don’t be afraid to try

• processing / analysis concepts and tips

• summary of software - choosing the right tool for the job (default to Fiji/ImageJ) 
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Resources
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• ImageJ and Fiji resources

• MRI ImageJ tutorial: http://www.mri.cnrs.fr/datas/fichiers/articles/60/183.pdf

• http://rsbweb.nih.gov/ij/

• http://fiji.sc/wiki/index.php/Fiji

• McMaster Biophotonics: http://www.macbiophotonics.ca/downloads.htm

• MATLAB demos: http://www.mathworks.co.uk/products/matlab/demos.html

• Digital Image Processing (Gonzalez & Woods), ISBN 013168728X

• Tracking resources

• MOSAIC group (ETH Zurich): http://www.mosaic.ethz.ch/

• Danuser lab: http://lccb.hms.harvard.edu/software.html

• Meijering lab: http://www.imagescience.org/meijering/software/
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